0029 - Funktion FINDEN

0029 - Funktion FINDEN

Im heutigen Tutorial wird die Funktion FINDEN() erläutert.
Mit der Funktion kann die Position bestimmt werden an welcher ein bestimmtes Wort in einer Zelle steht. Es wird die Position ausgegeben, an der das gesuchte Wort zum ersten Mal auftaucht. Der Unterschied zur Funktion SUCHEN ist, dass bei der Funktion FINDEN Gross- und Kleinschreibung unterschieden wird.
Die Funktion FINDEN() besitzt 3 Argumente:
   1.Suchtext: der Text, der gesucht werden soll.
   2.Text: die Spalte, in der gesucht werden soll.
   3.Position: die Position, ab der gesucht werden soll.
Die Eingabe einer Startposition ist optional. Wird hier kein Wert angegeben, beginnt Open Office Calc die Suche an der ersten Stelle.
Als Beispiel wird das Teilwort Ums in der Spalte A gesucht. Die Funktion kann sowohl direkt eingegeben werden oder über das Menü Funktion ausgewählt werden.

a. Eingabe der Funktion

Hierzu wird in der Zelle H2 folgende Eingabe getätigt: =FINDEN("ums";A2;1). Mit dieser Eingabe wird die Position bestimmt, an der das erste Mal die Wortfolge "ums" auftaucht.
Die Eingabe ist sowohl in der Zelle H2 als auch in der Eingabeleiste sichtbar:



Dies wird analog für die Zellen H3 bis H9 wiederholt:



b. Über die Menüleiste
Die Funktion kann auch über die Menüleiste gewählt werden: Im Menü unter Einfügen -> Funktion... auswählen.
Im Funktions-Assistent wird unter Funktion die Funktion FINDEN gewählt:



Mit Weiter>> wird die nächste Maske geöffnet. Mit folgenden Eingaben wird die Suche analog der oberen Eingabe durchgeführt:
--> Suchetext: "ums"
--> Text: A2
--> Position: 1



Zum Beenden des Assistenten wird auf OK geklickt.

Tipp: mit der WENN-Funktion (vgl. Tutorial 0025) und der Funktion ISTFEHLER (vgl. Tutorial 0024) kann der Fehlerwert #WERT! bspw. durch eine 0 ersetzt werden.
Dazu wird die folgende Eingabe getätigt: =WENN(ISTFEHLER(FINDEN("ums";A2;1));0;FINDEN("ums";A2;1))


Für Fragen, Hinweise und Anregungen können Sie uns unter der folgenden E-Mail-Adresse erreichen: Diese E-Mail-Adresse ist gegen Spambots geschützt! JavaScript muss aktiviert werden, damit sie angezeigt werden kann.