0049 - sverweis

0049 - sverweis

Bei dem heutigigen Tutorial wird die Funktion SVERWEIS() vorgestellt.

Mit dieser Funktion können Werte zu einem Suchkriterum dargestellt werden.
Die Beispieldatei wurde so geändert, dass die Umsätze für 2010 im Tabellenblatt Tabelle1 und die Umsätze für 2009 im Tabellenblatt Tabelle2 aufgelistet sind:





Die Umsätze des Jahres 2009 sollen in die Spalte C im Tabellenblatt Tabelle1 dargestellt werden.
Hierzu werden die Sparten in Spalte A im Tabellenblatt Tabelle2 mit Hilfe der Funktion SVERWEIS() gesucht und die Werte in die jeweilge Zelle der Spalte C übertragen.
Die Funktion SVERWEIS() besitzt 4 Argumente:
1. Suchkriterium: Der Wert nach dem gesucht werden soll.
2. Matrix: Der Bereich, der durchsucht werden soll und das Ergebnis enthält.
3. Spaltenindex: Die Spalte aus Matrix, die das Ergebnis enthält.
4. Bereich_Verweis: Hier wird angegeben, ob die erste Spalte der Matrix sortiert ist.
                                      Diese Eingabe ist optional. Wird hier keine Eingabe getätigt, dann geht Excel davon aus,
                                      dass eine Sortierung vorliegt.

Um die Funktion einzufügen, wird im Menü Einfügen auf Funktion... geklickt:


Es öffnet sich die Maske Funktion einfügen:



Hier wird bei Kategorie Alle ausgewählt und unter Funktion auswählen die Funktion SVERWEIS ausgewählt:



Die Auswahl wird mit OK bestätigt und es öffnet sich das Fentser Funktionsargumente:


Die Eingaben werden wie in der folgenden Abbildung vorgenommen:


Die Eingaben haben folgende Bedeutung:
Suchkriterum=A1: Der Inhalt der Zelle A1 ist das Suchkriterium.
Matrix = Tabelle2!A1:B9: Der Bereich von A1 bis B9 wird im Tabellenblatt Tabelle2 durchsucht
Spaltenindex = 2: Das Ergebnis ist in der 2. Spalte in der Matrix, d.h. in den Zellen B1 bis B9
Bereich_Verweis=0: Die Einträge in den Zellen A1 bis A9 im Tabellenblatt Tabelle2 sind nicht sortiert

Die Eingaben werden mit OK bestätigt.
In der Zelle C1 wird nun der Wert 2009 dargestellt:



Wird die Zelle C1 aktiviert, dann ist in der Eingabeleiste die Formel sichtbar:



Um die Formel in die Zellen C2 bis C9 zu kopieren, muß zunächst die Matrix, als der zudurchsuchende Bereich fixiert werden.
Hierfür wird die Formel wie folgt geändert: =SVERWEIS(A1;Tabelle2.$A$1:$B$9;2;0).
Durch die Ergänzung von A1:B9 auf $A$1:$B$9 wird der Bereich festgeschrieben.
Nun kann diese Eingabe in die darunter liegenden Zellen kopiert werden.
 Der Wert A1 ändert sich automatisch in A2, A3,.... Excel setzt die Zeilennummer automatisch.



Die jeweiligen Werte aus der Tabelle2 sind nun für alle Sparten dargestellt:



Wichtig:
die Spartenbezeichnungen in der Tabelle1 und der Tabelle2 müssen exakt gleich geschrieben sein, andernfalls findet Excel keine Übereinstimmung.
Zum Test wird in Tabelle1 die Sparte Bahnumsatz in Bahnumsatz1 geändert:



Die Formel in Tabelle1 findet für die Sparte Bahnumsatz nun keine Zuorndung mehr und gibt den Fehlerwert #NV aus:




Für Fragen, Hinweise und Anregungen können Sie uns unter der folgenden E-Mail-Adresse erreichen: Diese E-Mail-Adresse ist gegen Spambots geschützt! JavaScript muss aktiviert werden, damit sie angezeigt werden kann.